Cisco IOS Initial configuration is most important part for beginners, without understanding initial configuration and CLI modes correctly beginners will stuck. In this section scribe about basic Switch configure,
1) Time and date
2) Switch hostname
3) Privilege mode password
4) Console password
5) VTY (Telnet login password)
6) Service password encryption
7) Remote management (management ip address)
8) IP default-gateway
9) Save configuration
Switch>
Switch>enable
Switch#clock set ? ( if problem with some command, Type ? mark hit Enter key, hahaha Cisco IOS make me happy :) that's why Cisco IOS fame )
hh:mm:ss Current Time
Switch#clock set 17:43:00 ?
<1-31> Day of the month
MONTH Month of the year
Switch#clock set 17:43:00 june ?
<1-31> Day of the month
Switch#clock set 17:43:00 june 8 ?
<1993-2035> Year
Switch#clock set 17:43:00 june 8 2012
Switch#
Switch#configure terminal
Switch(config)#hostname SW1
SW1(config)# !configure privilege mode password type enable password your-password
SW1(config)#enable password madusanka
SW1(config)#line console 0 (entering line console sub configuration mode )
SW1(config-line)# exec-timeout 0 0 ( first 0 minute and second 0 mean second's, both 0 mean never time out)
SW1(config-line)#password madusanka (In my case password is madusanka)
SW1(config-line)# login (enable console login)
SW1(config-line)#exit
SW1(config)#
SW1(config)#
SW1(config)#line vty ?
<0-15> First Line number
SW1(config)#line vty 0 ?
<1-15> Last Line number
<cr>
SW1(config)#line vty 0 4 (if you type 0 - 15 that mean can 16 telnet session to switch )
SW1(config-line)#exec-timeout 0 0 (never timeout)
SW1(config-line)#password madusanka
SW1(config-line)#login
SW1(config-line)#exit
SW1(config)#
SW1(config)# do show running-config
SW1(config)#!my god that you see, my all password show in clear text, so how to fix that, get ready!
SW1(config)#service password-encryption (this command make my clean text password to MD7 encryption )
SW1(config)#do show running-config
What is a Remote Management ? In simply manege via SSH or telnet without connecting console cable, yes that's wright,
SW1(config)# inteface vlan 1 192.168.1.50 255.255.255.0 (management interface )
SW1(config-if)# ip address 192.168.1.50 255.255.255.0 (management ip address )
SW1(config-if)# no shutdown ( Interface activate command)
%LINK-5-CHANGED: Interface Vlan1, changed state to up
SW1(config-if)#exit
SW1(config)#ip default-gateway 192.168.1.1 ( where the exit )
SW1(config)#exit
SW1#
SW1#! Almost finish our basic configuration, final step is save current running-configuration to NVRAM
Destination filename [startup-config]?
Building configuration...
[OK]
SW1#
SW1# !#######################END#########################
1) Time and date
2) Switch hostname
3) Privilege mode password
4) Console password
5) VTY (Telnet login password)
6) Service password encryption
7) Remote management (management ip address)
8) IP default-gateway
9) Save configuration
Switch>
Switch>enable
Switch#clock set ? ( if problem with some command, Type ? mark hit Enter key, hahaha Cisco IOS make me happy :) that's why Cisco IOS fame )
hh:mm:ss Current Time
Switch#clock set 17:43:00 ?
<1-31> Day of the month
MONTH Month of the year
Switch#clock set 17:43:00 june ?
<1-31> Day of the month
Switch#clock set 17:43:00 june 8 ?
<1993-2035> Year
Switch#clock set 17:43:00 june 8 2012
Switch#
Switch#configure terminal
Switch(config)#hostname SW1
SW1(config)# !configure privilege mode password type enable password your-password
SW1(config)#enable password madusanka
SW1(config)#line console 0 (entering line console sub configuration mode )
SW1(config-line)# exec-timeout 0 0 ( first 0 minute and second 0 mean second's, both 0 mean never time out)
SW1(config-line)#password madusanka (In my case password is madusanka)
SW1(config-line)# login (enable console login)
SW1(config-line)#exit
SW1(config)#
SW1(config)#
SW1(config)#line vty ?
<0-15> First Line number
SW1(config)#line vty 0 ?
<1-15> Last Line number
<cr>
SW1(config)#line vty 0 4 (if you type 0 - 15 that mean can 16 telnet session to switch )
SW1(config-line)#exec-timeout 0 0 (never timeout)
SW1(config-line)#password madusanka
SW1(config-line)#login
SW1(config-line)#exit
SW1(config)#
SW1(config)# do show running-config
!
hostname SW1
!
enable password cisco
!
hostname SW1
!
enable password cisco
!
!
line con 0
password cisco
login
exec-timeout 0 0
!
line vty 0 4
exec-timeout 0 0
password madusanka
login
line con 0
password cisco
login
exec-timeout 0 0
!
line vty 0 4
exec-timeout 0 0
password madusanka
login
SW1(config)#!my god that you see, my all password show in clear text, so how to fix that, get ready!
SW1(config)#service password-encryption (this command make my clean text password to MD7 encryption )
SW1(config)#do show running-config
!
hostname SW1
!
enable password 7 0822455D0A16 <--- see it ?
!
!
hostname SW1
!
enable password 7 0822455D0A16 <--- see it ?
!
!
line con 0
password 7 0822455D0A16 <--- see it ?
login
exec-timeout 0 0
!
line vty 0 4
exec-timeout 0 0
password 7 082C4D4A1C0A0419190A <--- see it ?
login
SW1(config)#password 7 0822455D0A16 <--- see it ?
login
exec-timeout 0 0
!
line vty 0 4
exec-timeout 0 0
password 7 082C4D4A1C0A0419190A <--- see it ?
login
What is a Remote Management ? In simply manege via SSH or telnet without connecting console cable, yes that's wright,
SW1(config)# inteface vlan 1 192.168.1.50 255.255.255.0 (management interface )
SW1(config-if)# ip address 192.168.1.50 255.255.255.0 (management ip address )
SW1(config-if)# no shutdown ( Interface activate command)
%LINK-5-CHANGED: Interface Vlan1, changed state to up
SW1(config-if)#exit
SW1(config)#ip default-gateway 192.168.1.1 ( where the exit )
SW1(config)#exit
SW1#
SW1#! Almost finish our basic configuration, final step is save current running-configuration to NVRAM
, type copy running-config startup-config in privilage mode, and any other place you can used do write
SW1#copy running-config startup-configDestination filename [startup-config]?
Building configuration...
[OK]
SW1#
SW1# !#######################END#########################